CVE-2026-108374
highERPNext is a free and open source Enterprise Resource Planning tool.
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.121.0 and 16.34.0, certain endpoints for status modification fail to enforce proper authorization checks. A low-privileged authenticated user can invoke state-changing whitelisted methods without required write, submit, cancel, document, or role checks. This allows the user to modify data beyond the user's permitted role. This issue is fixed in versions 15.121.0 and 16.34.0.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/frappe/erpnext/commit/547d82da563380a0644919173e00d0205f986d89 security-advisories@github.com
- https://github.com/frappe/erpnext/commit/86e94803629ea5668c2fc2d18afb5ca59fe2cf03 security-advisories@github.com
- https://github.com/frappe/erpnext/commit/a20fc4f9317ecc7d262625aea680c9a0cda98cef security-advisories@github.com
- https://github.com/frappe/erpnext/releases/tag/v15.121.0 security-advisories@github.com
- https://github.com/frappe/erpnext/releases/tag/v16.34.0 security-advisories@github.com
- https://github.com/frappe/erpnext/security/advisories/GHSA-5wpj-6rvp-9ff7 security-advisories@github.com
