CVE-2026-108822
mediumA vulnerability was detected in Kamailio up to 6.0.7/6.1.3.
A vulnerability was detected in Kamailio up to 6.0.7/6.1.3. The affected element is the function isup_get_calling_party of the file src/modules/sipt/ss7_parser.c of the component sipt Module. The manipulation of the argument length results in buffer overflow. The attack may be performed from remote. Upgrading to version 6.0.8 and 6.1.4 is sufficient to fix this issue. The patch is identified as 3667bebf8d0bea07ed16218fd921d07db87aeb21. Upgrading the affected component is advised.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/kamailio/kamailio/ cna@vuldb.com
- https://github.com/kamailio/kamailio/commit/3667bebf8d0bea07ed16218fd921d07db87aeb21 cna@vuldb.com
- https://github.com/kamailio/kamailio/pull/4905 cna@vuldb.com
- https://github.com/kamailio/kamailio/releases/tag/6.0.8 cna@vuldb.com
- https://vuldb.com/cve/CVE-2026-108822 cna@vuldb.com
- https://vuldb.com/submit/964495 cna@vuldb.com
- https://vuldb.com/vuln/416599 cna@vuldb.com
- https://vuldb.com/vuln/416599/cti cna@vuldb.com
