CVE-2026-110310
mediumA remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to…
A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object. To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://aws.amazon.com/security/security-bulletins/2026-135-aws/ ff89ba41-3aa1-4d27-914a-91399e9639e5
- https://github.com/aws/amazon-s3-encryption-client-dotnet/security/advisories/GHSA-322w-f6... ff89ba41-3aa1-4d27-914a-91399e9639e5
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/3.2.2 ff89ba41-3aa1-4d27-914a-91399e9639e5
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/4.0.3 ff89ba41-3aa1-4d27-914a-91399e9639e5
