CVE-2026-112105
lowA vulnerability has been found in GlitterWare Passy up to 1.10.1.
A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/GlitterWare/Passy/ cna@vuldb.com
- https://github.com/GlitterWare/Passy/commit/3d48df7cce05e39fa4de1e42768492307f26882e cna@vuldb.com
- https://github.com/GlitterWare/Passy/issues/210 cna@vuldb.com
- https://github.com/GlitterWare/Passy/releases/tag/v1.10.2 cna@vuldb.com
- https://vuldb.com/cve/CVE-2026-112105 cna@vuldb.com
- https://vuldb.com/submit/1013135 cna@vuldb.com
- https://vuldb.com/vuln/422055 cna@vuldb.com
- https://vuldb.com/vuln/422055/cti cna@vuldb.com
