CVE-2026-112957
mediumApostropheCMS is an open-source Node.js content management system.
ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, the getOne REST endpoint for pages does not apply viewRole type-level restrictions or viewPermission field-level redaction. An editor-level user who knows a document _id can read the full content of admin-only pages and their privileged fields, while the getAll endpoint correctly enforces both restrictions. This issue is fixed in version 4.34.0.
CVSS
4.3
4.3 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N Severity source: NVD CVSS v3.1 (security-advisories@github.com)
Timeline (UTC)
Published: 2026-10-20 17:17
Modified: 2026-10-21 16:17
NVD status: Deferred
Last synced 1 day ago
Verified against the source API 2026-10-27 07:04 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/apostrophecms/apostrophe/commit/06e4b377f3c360f9e89c32dccd7e505ad5ddf49... security-advisories@github.com
- https://github.com/apostrophecms/apostrophe/commit/40b989b1a9dd23d30029b8ce7668634265cfe5e... security-advisories@github.com
- https://github.com/apostrophecms/apostrophe/releases/tag/apostrophe@4.34.0 security-advisories@github.com
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-vh56-5m88-39rq security-advisories@github.com
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 07:04 UTC · record ↗
