CVE-2026-28384
criticalAn improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daem…
Vendor / product: Canonical — lxd
An improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daemon on the LXD server via API calls to the image and backup endpoints. This issue affected LXD from 4.12 through 6.6 and was fixed in the snap versions 5.0.6-e49d9f4 (channel 5.0/stable), 5.21.4-1374f39 (channel 5.21/stable), and 6.7-1f11451 (channel 6.0 stable). The channel 4.0/stable is not affected as it contains version 4.0.10.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H Affected products
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
References
- https://discourse.ubuntu.com/t/lxd-authenticated-remote-code-execution-fixes-available/783... security@ubuntu.com
- https://github.com/canonical/lxd/commit/043696a13171ace7dd4c2b32d34ce039ab629052 security@ubuntu.com
- https://github.com/canonical/lxd/commit/7046979645c2ce1b63b2f9e60ddf6cbc4c4b78f9 security@ubuntu.com
- https://github.com/canonical/lxd/commit/b7b411caf5c4971bfe2386c72128f44d7e2aaf4f security@ubuntu.com
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g security@ubuntu.com
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g 134c704f-9b21-4f2e-91b3-4a467353bcc0
