CVE-2026-34236
criticalAuth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs.
Vendor / product: Auth0 — auth0-php
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
CVSS
9.8
9.8 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Severity source: NVD CVSS v3.1 (nvd@nist.gov)
Timeline (UTC)
Published: 2026-04-01 18:16
Modified: 2026-10-26 21:10
NVD status: Analyzed
Last synced 2 days ago
Verified against the source API 2026-10-27 07:07 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
auth0 / auth0-php ≥8.0.0 <8.19.0
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
References
- https://github.com/auth0/auth0-PHP/releases/tag/8.19.0 security-advisories@github.com
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-w3wc-44p4-m4j7 security-advisories@github.com
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 07:07 UTC · record ↗
