CVE-2026-46420
criticalsetup-php is a GitHub action to set up PHP with extensions, php.ini configuration, coverage drivers, and tools.
Vendor / product: Shivammathur — setup php
setup-php is a GitHub action to set up PHP with extensions, php.ini configuration, coverage drivers, and tools. From 2.25.0 prior to 2.37.1, shivammathur/setup-php resolves the PHP version from repository-controlled files such as .php-version, composer.lock through platform-overrides.php, and composer.json through config.platform.php, and insufficiently constrains those values before incorporating them into generated shell or PowerShell setup scripts, allowing command injection on a GitHub Actions runner when workflows such as pull_request_target check out attacker-controlled contents before invoking setup-php. This issue is fixed in version 2.37.1.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Affected products
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
References
- https://github.com/shivammathur/setup-php/commit/eeef37e059fb5368a5bc8ed8ce45ff54bd39b80b security-advisories@github.com
- https://github.com/shivammathur/setup-php/releases/tag/2.37.1 security-advisories@github.com
- https://github.com/shivammathur/setup-php/security/advisories/GHSA-pqwm-q9pv-ph8r security-advisories@github.com
