CVE-2026-49871
criticalCross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations.
Vendor / product: Apache — apisix
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
CVSS
9.3
9.3 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N Severity source: NVD CVSS v3.1 (nvd@nist.gov)
Timeline (UTC)
Published: 2026-06-19 14:16
Modified: 2026-10-26 11:10
NVD status: Analyzed
Last synced 2 days ago
Verified against the source API 2026-10-27 07:07 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
apache / apisix ≥3.0.0 <3.17.0
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
Vendor advisory: https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp
References
- https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp security@apache.org
- http://www.openwall.com/lists/oss-security/2026/06/19/14 af854a3a-2127-422b-91ae-364da2661108
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 07:07 UTC · record ↗
