CVE-2026-58185
criticalThe Apache Traffic Server intercept plugin has a use-after-free.
Vendor / product: Apache — traffic server
The Apache Traffic Server intercept plugin has a use-after-free. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
CVSS
9.8
9.8 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Severity source: NVD CVSS v3.1 (nvd@nist.gov)
Timeline (UTC)
Published: 2026-07-29 10:16
Modified: 2026-10-01 18:17
NVD status: Modified
Last synced 2 days ago
Verified against the source API 2026-10-27 07:07 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
apache / traffic_server ≥8.0.0 ≤8.1.9, ≥9.0.0 <9.2.15, ≥10.0.0 <10.1.4
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
Vendor advisory: https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d
References
- https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d security@apache.org
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 07:07 UTC · record ↗
