CVE-2026-76086
highFormie is a Craft CMS plugin for creating forms.
Formie is a Craft CMS plugin for creating forms. Prior to 2.2.23 and 3.1.31, Formie's formie/integrations/form-settings control panel action in IntegrationsController::actionFormSettings is reachable without the required form integration permissions and passes request-supplied settings to a configured integration. An authenticated attacker can replace outbound host properties such as apiUrl while the server uses stored API keys or OAuth tokens, causing non-blind server-side requests to an attacker-controlled or internal host and returning the remote response. This residual flaw remained because the permission gate added in version 3.1.28 excluded the form-settings action. Sites that permit low-privileged or front-end user authentication can therefore expose integration credentials and internal network responses. This issue is fixed in versions 2.2.23 and 3.1.31.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/advisories/GHSA-cvpc-hccg-wmw4 security-advisories@github.com
- https://github.com/verbb/formie/commit/6735fe4ae8f6a2a76930716ad7876b236f7c530d security-advisories@github.com
- https://github.com/verbb/formie/commit/dde7799dfa7e4d0a11e28754ad8544dba62d5def security-advisories@github.com
- https://github.com/verbb/formie/releases/tag/2.2.23 security-advisories@github.com
- https://github.com/verbb/formie/releases/tag/3.1.31 security-advisories@github.com
- https://github.com/verbb/formie/security/advisories/GHSA-v3f3-cmj4-cvj9 security-advisories@github.com
