CVE-2026-77405
Severity not reportedRabbitMQ amqp091-go is a Go AMQP 0.9.1 client.
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e security-advisories@github.com
- https://github.com/rabbitmq/amqp091-go/pull/355 security-advisories@github.com
- https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0 security-advisories@github.com
- https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h security-advisories@github.com
