CVE-2026-8145
mediumThe WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all version…
The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://plugins.trac.wordpress.org/browser/wholesalex/tags/2.3.7/includes/menu/class-whole... security@wordfence.com
- https://plugins.trac.wordpress.org/browser/wholesalex/trunk/includes/menu/class-wholesalex... security@wordfence.com
- https://plugins.trac.wordpress.org/changeset/3529605/ security@wordfence.com
- https://plugins.trac.wordpress.org/changeset/3703929/ security@wordfence.com
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d3b9464c-dcc4-4ae8-816f-1572f84d... security@wordfence.com
