CVE-2026-81883
lowradare2 is a UNIX-like reverse engineering framework and command-line toolset.
Vendor / product: Radare — radare2
radare2 is a UNIX-like reverse engineering framework and command-line toolset. Prior to 6.2.0, radare2's Lua 5.3 bytecode function parser was vulnerable because the Lua 5.3 bytecode function parser read fixed function-metadata fields immediately after a function-name string without checking the remaining buffer length. The vulnerability is triggered by opening or inspecting a crafted Lua 5.3 bytecode file whose function-name string ends at the input-buffer boundary. The parser read two integers and three one-byte fields beyond the allocated input buffer. This can cause invalid parser results or process termination; no attacker-observable memory disclosure has been demonstrated. This issue is fixed in version 6.2.0.
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L Affected products
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
References
- https://github.com/radareorg/radare2/commit/26c2eac360033458e9d266e5e30667d1f8d642e3 security-advisories@github.com
- https://github.com/radareorg/radare2/issues/26228 security-advisories@github.com
- https://github.com/radareorg/radare2/releases/tag/6.2.0 security-advisories@github.com
- https://github.com/radareorg/radare2/security/advisories/GHSA-96m5-hvwp-674c security-advisories@github.com
- https://github.com/radareorg/radare2/issues/26228 134c704f-9b21-4f2e-91b3-4a467353bcc0
