CVE-2026-84188
mediumLibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.
LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr. configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.
CVSS
4.8
4.8 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N Severity source: NVD CVSS v3.1 (disclosure@vulncheck.com)
Timeline (UTC)
Published: 2026-09-01 12:17
Modified: 2026-10-08 16:17
NVD status: Deferred
Last synced 2 days ago
Verified against the source API 2026-10-27 06:50 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/librenms/librenms/security/advisories/GHSA-7cj5-v4pp-v632 disclosure@vulncheck.com
- https://www.vulncheck.com/advisories/librenms-before-26.7.0-stored-xss-via-graph-descr-set... disclosure@vulncheck.com
- https://github.com/librenms/librenms/security/advisories/GHSA-7cj5-v4pp-v632 134c704f-9b21-4f2e-91b3-4a467353bcc0
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 06:50 UTC · record ↗
