CVE-2026-85241
mediumA weakness has been identified in SpecterOps BloodHound up to 9.5.1.
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/SpecterOps/BloodHound/ cna@vuldb.com
- https://github.com/SpecterOps/BloodHound/commit/39d1276a63e95a7713f954dea632a19651d9cebb cna@vuldb.com
- https://github.com/SpecterOps/BloodHound/releases/tag/v9.6.0-rc1 cna@vuldb.com
- https://vuldb.com/cve/CVE-2026-85241 cna@vuldb.com
- https://vuldb.com/submit/894488 cna@vuldb.com
- https://vuldb.com/vuln/398471 cna@vuldb.com
- https://vuldb.com/vuln/398471/cti cna@vuldb.com
