CVE-2026-86243
highBuffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.
Vendor / product: Apache — tomcat native
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
CVSS
7.5
7.5 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H Severity source: NVD CVSS v3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
Timeline (UTC)
Published: 2026-09-23 13:17
Modified: 2026-10-06 13:53
NVD status: Analyzed
Last synced 2 days ago
Verified against the source API 2026-10-27 06:55 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
apache / tomcat_native ≥1.3.0 <1.3.9, ≥2.0.0 <2.0.16
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
Vendor advisory: https://lists.apache.org/thread/8p4jf02w54m22x0cwpq2x53w3ov8o557
References
- https://lists.apache.org/thread/8p4jf02w54m22x0cwpq2x53w3ov8o557 security@apache.org
- http://www.openwall.com/lists/oss-security/2026/09/23/31 af854a3a-2127-422b-91ae-364da2661108
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 06:55 UTC · record ↗
