CVE-2026-86247
highRace condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurat…
Vendor / product: Apache — tomcat native
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
CVSS
7.4
7.4 (CVSS v3.1)
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N Severity source: NVD CVSS v3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
Timeline (UTC)
Published: 2026-09-23 13:17
Modified: 2026-10-06 13:46
NVD status: Analyzed
Last synced 2 days ago
Verified against the source API 2026-10-27 06:55 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
apache / tomcat_native ≥1.3.0 <1.3.9, ≥2.0.0 <2.0.16
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
Vendor advisory: https://lists.apache.org/thread/obsson6zhvfg0wsp2bx602l61ltj87r1
References
- https://lists.apache.org/thread/obsson6zhvfg0wsp2bx602l61ltj87r1 security@apache.org
- http://www.openwall.com/lists/oss-security/2026/09/23/33 af854a3a-2127-422b-91ae-364da2661108
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 06:55 UTC · record ↗
