CVE-2026-94212
Severity not reportedData quality: partial.
Some fields were not provided by the source.
Improper verification of cryptographic signature vulnerability in Apache APISIX.
Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
CVSS
—
Not reported by the source
Timeline (UTC)
Published: 2026-10-01 12:17
Modified: 2026-10-01 15:17
NVD status: Deferred
Last synced 2 days ago
Verified against the source API 2026-10-27 06:56 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://lists.apache.org/thread.html/1230fnojnmc7bfz3n0nkt7tkcld9d1sc security@apache.org
- http://www.openwall.com/lists/oss-security/2026/10/01/4 af854a3a-2127-422b-91ae-364da2661108
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 06:56 UTC · record ↗
