CVE-2026-96883
highpgcollection is an open source extension to PostgreSQL.
pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions. To remediate this issue, users should upgrade to version 2.1.2 or later.
CVSS
8.8
8.8 (CVSS v3.1)
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H Severity source: NVD CVSS v3.1 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
Timeline (UTC)
Published: 2026-09-24 20:17
Modified: 2026-09-25 13:16
NVD status: Awaiting Analysis
Last synced 2 days ago
Verified against the source API 2026-10-27 06:55 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://aws.amazon.com/security/security-bulletins/2026-118-aws/ ff89ba41-3aa1-4d27-914a-91399e9639e5
- https://github.com/aws/pgcollection/releases/tag/v2.1.2 ff89ba41-3aa1-4d27-914a-91399e9639e5
- https://github.com/aws/pgcollection/security/advisories/GHSA-g539-cj32-hv6r ff89ba41-3aa1-4d27-914a-91399e9639e5
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 06:55 UTC · record ↗
