CVE-2026-107812
highNginx UI is a web user interface for the Nginx web server.
Vendor / product: Nginxui — nginx ui
Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the self-upgrade mechanism validates a downloaded binary only with a same-origin digest obtained from the same upgrade mirror. A compromised mirror or network attacker able to alter both responses can supply a malicious executable and matching digest. An operator-triggered upgrade is required, and the application installs and runs the attacker-controlled code in the Nginx UI process context on the next upgrade. This issue is fixed in version 2.5.0.
CVSS
7.5
7.5 (CVSS v3.1)
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H Severity source: NVD CVSS v3.1 (security-advisories@github.com)
Timeline (UTC)
Published: 2026-10-09 16:17
Modified: 2026-10-20 14:48
NVD status: Analyzed
Last synced 1 day ago
Verified against the source API 2026-10-27 06:58 UTC
Exploitation
Not listed in CISA KEV (as of last catalog sync)
Absence from KEV does not mean a CVE is not exploited. Exploitation status: unknown (no authoritative evidence in our sources).
Affected products
nginxui / nginx_ui ≥2.0.0 <2.5.0
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
References
- https://github.com/0xJacky/nginx-ui/commit/580585516dd87a8b176bcdac258db70c3b64b7ec security-advisories@github.com
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0 security-advisories@github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2 security-advisories@github.com
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2 134c704f-9b21-4f2e-91b3-4a467353bcc0
Data sources
NVD CVE API 2.0 — fetched 2026-10-27 06:58 UTC · record ↗
